Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
Instalación de FacturaScripts 2018

Requisitos

Los requisitos para la versión 2018 son:

  • PHP 7.0.8 o superior.
  • Apache u otro servidor web compatible con PHP.
  • MySQL 5.5 o superior, o PostgreSQL 8.0 o superior.

También se necesita que la instalación de PHP tenga las siguientes extensiones activadas:

  • bcmath
  • curl
  • simplexml
  • openssl
  • zip

¿Son unos requistos altos?

Lo cierto es que no. Hoy en día todas las aplicaciones PHP se están desarrollando sobre PHP 7. En cuanto a las extensiones necesarias, realmente son las extensiones que vienen por defecto en cualquier instalación de PHP, y que debe cumplir cualquier hosting PHP.

¿Cómo saber si cumplo los requisitos?

El propio instalador le informará si falla algún requisito. Además, en la esquina superior derecha tiene un botón phpinfo en el que si hace clic podrá ver todos los detalles de tu instalación PHP.

Mi hosting no cumple los requisitos ¿Que hago?

Cambie de hosting, así de claro. A lo largo de estos años nos hemos encontrado multitud de hostings que recortan las características de PHP o MySQL de forma absurda, o que utilizan extensiones con más de 10 años de antigüedad y numerosas vulnerabilidades.

En el pasado hemos intentado esquivar estos problemas programando soluciones alternativas en el núcleo, pero llega un punto que es absurdo. Perdemos más tiempo de desarrollo en parchear los problemas de los hostings que en añadir nuevas características realmente interesantes para los usuarios. Por eso en esta nueva versión hemos decidido dejar de parchear los problemas de los hostings. Elija un hosting que no recorte la instalación de PHP o MySQL.