Esta web utiliza cookies propias y de terceros para su funcionamiento. ¿Aceptas? Leer más
Instalación de FacturaScripts 2018

Problemas frecuentes

Esta es una pequeña lista de problemas frecuentes tras la instalación de FacturaScripts 2018.

COMPOSER ERROR: You need to run: composer install

Necesitas instalar y ejecutar composer install en la carpeta de FacturaScripts. Además necesitará instalar npm.

404: página no encontrada

Es necesario instalar y activar el mod rewrite en el Apache, así como permitir el uso de .htaccess en la carpeta de FacturaScripts. Generalmente en Ubuntu, o derivados, es necesario modificar el archivo /etc/apache2/apache2.conf y poner AllowOverride All en la carpeta /var/www/html

Siempre me carga la página de Plugins o Wizard

Independientemente de la opción del menú que elija, siempre me aparece Admin -> Plugins.

Este comportamiento indica un problema con el mod rewrite del Apache. Es necesario permitir el uso de .htaccess en la carpeta de FacturaScripts. Generalmente en Ubuntu, o derivados, es necesario modificar el archivo /etc/apache2/apache2.conf y poner AllowOverride All en la carpeta /var/www/html

En otros servidores web es recomendable indicar que todo el tráfico lo dirija al archivo index.php, en lugar de a la carpeta. Así FacturaScripts se encarga del enrutado.